본문 바로가기

네트워크

[정보기기운용기능사] 명령어 정리

enable(운영자모드)
conf t(설정모드)

메모리 내용확인
show flash                     Flash 내용확인
show running-config       Ram 메모리 내용확인
show startup-config        NVRAM 메모리 확인

show ip nat translations   주소 변환 테이블 확인


(config)# hostname R1    해당 장비의 hostname 변경

(config)# int f0/0
(config-if)# ip address [Address] [Subnet-Mask] 인터페이스 f0/0에 정적으로 아이피 할당

(config-if)# banner motd # Welcome to Digital World! # 배너 설정

History config--------------------------------

#terminal history size 20    히스토리 사이즈 설정
#show histroy                  히스토리 목록 확인

DNS 정보 config--------------------------------

(config)# ip host [Domain_name] [IP_Address]    HOST정보를 추가함(DNS 기능)ㅋ
(config)# ip domain-lookup                                 DNS Lookup 기능 실행
(config)# no ip domain-lookup                             DNS 질의 하지 않음

Enable Password config-------------------------------

(config)# enable password #admin123#                Enable 접속시 패스워드 입력
(config)# enable secret #admin123#                     위와 같은 기능이나 패스워드가 암호화되어 저장됨

Password config--------------------------------

(config)# line console 0
(config-if)# password #consolepw#                    암호 설정
(config-if)# login                                                기본 암호로 로그인

(config)# line vty 0 4
(config-if)# password #telnetPw#                    암호 설정
(config-if)# login                                                기본 암호로 로그인

exec-timeout config--------------------------------

(config)# username [USER_NAME] password(or secret) [USER_PW]    로컬 아이디와 패스워드 설정
(config)# line console 0
(config-if)# login local                    로컬 인증 사용

(config-if)# exec-timeout 3 30          입력 안한지 3분 30초 후 자동 로그아웃
//exec-timeout 0 0 or no exec-timeout 을 입력하면 디폴트 또는 사용자가 설정한 타임아웃 시간은 없앤다.

COPY Flash: tftp: config--------------------------------

#copy flash: tftp:
Source filename []? c2800nm-advipservicesk9-mz.124-15.T1.bin
Address or name of remote host []? [TARGET_TFTP_SERVER_ADDRESS]
Destination filename [asdfsdfsdfsdf] ? [변경할 bin파일의 파일이름]

VLAN config--------------------------------

#int f0/0
(config-if)# no shutdown
(config-if)# exit
#int f0/0.10
(config-if)# encapsulation dot1Q 10
(config-if)# ip add [해당 VLAN의 게이트웨이 아이피] [SUBNETMASK]
(config-if)# exit

Serial Interface config--------------------------------

(config)# int s0/0/0
(config-if)# ip add [IP_ADDRESS] [IP_SUBNETMASK]
(config-if)# clock rate 64000
(config-if)# no shutdown

PAP config--------------------------------

(config)# username ISP password #admin123#
(config)# int s0/0/0
(config-if)# encapsulation ppp
(config-if)# ppp authentication pap
(config-if)# ppp pap sent-username R1 password #admin123#
//PAP(PPP Authentication Protocol)은 pap에 설정해둔 대상 장비의 username과 password을 보내 해당 장비에게 접속을 인증하는 방식, ppp는 시스코장비다 다른 회사의 장비에 접속할 때 사용하는 방식

CHAP config--------------------------------

(config)# username ISP password #admin123#
(config-if)# int s0/0/0
(config-if)# encapsulation ppp
(config-if)# ppp authentication chap
//PAP는 전송할 username과 passsword를 따로 설정했지만 ppp chap은 로컬 인증을 그대로 사용해 보내는 방식, 또한 3-handshaking과정을 통해 주기적인 세션확인과 md5형태로 사용자의 username과 password를 보냄

Passvie-interface config-------------------------------

(config)# router rip
(config-router)# passive-interface f0/0         f0/0에 라우팅정보를 보내지 않도록 설정

ssh config------------------------------------------

(config)# ip domain-name digital.com
(config)# username admin password #admin123#
(config)# line vty 0 4
(config-line)# login local
(config-line)# transport input ssh
(config-line)# crypto key generate rsa

DHCP config------------------------------------------

(config)# int f0/0
(config-if)#ip add 210.100.100.1 255.255.255.0
(config-if)#no shutdown
(config-if)#exit
(config)#ip dhcp pool digital
(dhcp-config)#netowork 210.100.100.0 255.255.255.0
(dhcp-config)#default-router 210.100.100.1
(dhcp-config)#exit
(config)#ip dhcp excluded-address 210.100.100.1
(config)#ip dhcp excluded-address 210.100.100.255

Root Bridge Config------------------------------------------

(config)# spanning-tree vlan 30 priority 4000

Portfast config--------------------------------

(config)#int f0/0
(config-if)#spanning-tree portfast

Port Security config--------------------------------

(config)# int f0/0
(config-if)# switchport mode access
(config-if)# switchport port-security
(config-if)# switchport port-security mac-address 0000.0000.fffff
(config-if)# switchport port-security violation shutdown

VLAN-VTP config----------------------------------

S1
(config)# vtp version 2
(config)# vtp mode server
(config)# vtp domain digital
(config)# vtp password #admin123#

S2
(config)# vtp version 2(config)# vtp mode client
(config)# vtp domain digital
(config)# vtp password #admin123#

VTP는 스위치간의 vlan 정보를 일치시켜주기 위해서 동작하는 프로토콜입니다.

VLAN config-------------------------------------

1. 스위치의 vlan database vlan 등록
2. 스위치의 각 포트별로 해당 vlan을 할당시킴

VLAN-Trunking config----------------------------

(config-if)# switch mode trunk

Default Gateway config---------------------------

(config)# ip default-gateway [IP-ADDRESS]

Routing Rip Version 2 config----------------------

ISP(config)#router rip
ISP(config-router)#version 2
ISP(config-router)#net 192.168.1.0
ISP(config-router)#net 192.168.2.0
ISP(config-router)#net 192.168.3.0
ISP(config-router)#net 210.150.10.0
ISP(config-router)#exit

Routing OSPF config------------------------------

R1(config)#router ospf 7
R1(config-router)#network 210.150.10.0 0.0.0.255 area 0

Routring EIGRP config-------------------------------------

ISP(config)#router eigrp 7

ISP(config-router)#network 192.168.1.0

ISP(config-router)#network 192.168.2.0

ISP(config-router)#network 192.168.3.0

ISP(config-router)#network 210.150.10.0

ISP(config-router)#exit

Standard ACL config----------------------------------------------

Setting
access-list [1-99, 1300-1900] [permit | deny] [host IP_ADDR, A.B.C.D NetMask, any]

적용
(config-if)# access-class [1-99, 1300-1900] [in/out]

Extend ACL config----------------------------------------------------------

Setting
access-list [100-199, 200-2699] [deny/permit] [protocol] [source_host/network] [destination_host/network] [OPTION: protocol]

적용
(config-if)# ip access-group [100-199, 200-2699] [in/out]

AAA Radius authority Config-----------------------------------------------------------

ISP(config)#username admin password #admin123#

ISP(config)#aaa new-model 

ISP(config)#aaa authentication login default group radius local

ISP(config)#radius-server host 150.65.10.1

ISP(config)#radius-server key digital

ISP(config)#line console 0

ISP(config-line)#login authentication default

ISP(config-line)#exit

Static NAT config--------------------------------------------------

R1(config)#ip nat inside source static 210.100.100.2 203.230.8.3

R1(config)#int f0/0

R1(config-if)#ip nat outside

R1(config-if)#int f0/1

R1(config-if)#ip nat inside 

R1(config-if)#exit

Dynamic NAT config---------------------------------------------

ip nat pool digital 203.230.8.7 203.230.8.15 netmask 255.255.255.0
access-list 100 permit ip host 210.100.100.2 110.100.100.0 0.0.0.255
ip nat inside source list 100 pool digital
(config-if)# ip nat inside
(config-if)# ip nat outside

PAT config------------------------------------------------

ip nat inside source list 100 int f0/0 overload
access-list 100 permit ip host 210.100.100.2 110.100.100.0 0.0.0.255
(config-if)# ip nat inside
(config-if)# ip nat outside